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7.4 New Features

File Import / Export

e ASCII PLY file (also known as the “Stanford Triangle Format”) import / export for surfaces,
tracemaps and point data sets.

e ESRI Shapefile import / export for surfaces, tracemaps and point data sets.
e Vulcan surface ASCIl import/export is complete
e Import / export IRAP, CPS3 and ZMap+ lines files (tracemap objects).

e Large file support for interpolating large ascii files to property values. When this option is
selected the file will be parsed and interpolated one line at a time — this allows interpolation of
multi-gigabyte ASCII files on a normal class machine. This interpolation is basically linear with
the size of the file and can take hours to days to complete.

e New .fro (FracMan Object) file format which supports single/multiple objects/definitions in a
binary format for simple exchange between .frd models.

e Progress bar with cancel support has been added to .frd file load

Parameter Sweeping

Named Parameters
You define a named parameter by selecting Tools -> Monte Carlo / Optimization -> Define Named
Parameter, giving it a name and specifying a default value.

Define Named Parameter u

Name: |

You can use a named parameter any place you see the new parameter edit box:

Target Intensity 200 »
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Remember that you can always use a number — but these boxes will also accept a parameter name as

well.

When a named parameter is specified, the analysis will use the current (or default) value of that
parameter. Named parameters are not currently supported by the macro language.

Parameter Sweep
If you select Tools->Monte Carlo / Optimization -> Define Parameter Sweep / Optimization you can

define the sweep range for any named parameters in your model. You can specify a constant value, a
min/max/step or a list of discreet values. In place of a standard monte carlo analysis, the selected
fracture generation / analyses will be run once for every point in the parameter space defined.

| Monte Carlo Analysis | Parameters | Fracture Sets | Select Analysis |

Mamed Parameters

Parameter Name: MamedParam 1

i7) Constant Value ] |

@ Range min | 2.2204460492503 max 100
Num Steps: 3 logarithmic steps
i) Value List |z”£”1”2| !l
L
ok | [ Cancel ] | Apply
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Edit Features
Create point data from objects

This will create a point data set from virtually any object

Copy selected object names
This will copy the names of any selected objects to the clipboard.

Ul Improvements

* The objects bar now has autoscroll when in drag and drop

® The objects bar drag and drop supports multi-select

e Added right click menu for copy/paste/delete to well definition dialog

e Added ctrl+C handler to log window

e Added ctrl+G shortcut to add object group

e Improved support for context sensitive help / context specific help “popups”

Create well log subsets from well intervals

It is now simpler to separate well logs into subsets by depth range. If you set up all your intervals of

interest as interval sets you can create well logs of those intervals over your entire model in one
operation.

High resolution screen shots
You can now take screen shots at higher than screen resolution.

g —
High Resolution Rendering .

Screen Scale Factor: 3 [1..n]

Image Size: 2064 X 2156

Copy to dipboard
Save to File

C:\kest.bmp
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These beautiful images are useful for publication where high dpi images are required. Select “High
Resolution Screen Capture” and enter a scale factor — the resulting image will be captured at this many
times the size of the current window. You can save the image to the clipboard or save it directly to file
in a number of different image formats. For best results you should also select “Enable Multisampling”
from the “Display Options” page of the options dialog.

Triangulate Points
This will generate a surface object out of a set of point data.

Compute Coordinate Frame

This will create a set of coordinate reference frame properties from surface face orientations. It was
designed to simplify the use of coordinate reference frames by allowing you to quickly compute the

necessary properties based on the normal vectors of a controlling surface. You can then interpolate
these property values to a grid in order to have the necessary coordinate reference frame.

Define Stress Properties

This feature simplifies the definition of the stress field properties used by the Critical Stress Analysis and
the Stress Propagation fracture generation. You can select existing property names for each of the
principal values or enter your own as well as specifying a constant property value.

| Define Stress Pruperties_ u1
Selected Grids: Property Name: Value:
[¥]BasicGrid Sigma 1 Sigmal 1
Sigma 2 Sigma2 1
Sigma 3 Sigma3 1
Sigma 1 Trend Sigmal_Trend 0
Sigma 1 Plunge Sigma1_Plunge 90
Sigma 3 Trend  Sigma3_Trend 0
Sigma 3 Plunge Sigma3_Plunge 0

Surface decimation 2D hull outline option

Closed surfaces don’t have outer edges that we use to bound the surface decimation. This option will
compute the 2D convex hull of the object (projected in the selected direction) to enable surface
decimation of these objects.
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Variable Thickness Layers in Grid Between Surfaces
When generating a grid between two surfaces you can now specify non-uniform layer thicknesses.

Select “Uneven layer thicknesses” and specify the fractional layer width of each layer (0 —1). The total
must add up to 1.0.

FracMan7 Manual -vi- ©2010, Golder Associates Inc.



-
(Generate Grid Between Surfaces — g
M ame
Surface Region Grid
Surfaces
Surface 1 [ Traceplane_top - ]
Surface 2 [Traceplane_h::nttcnm v]
[arid Geornety
= Y £
i@ Mumber of Cells; 10 30 [# of layers]
]
(7 Cell Dimensions: |'|5|:|'| 5 | |1499.EI |
[¥]ireven laver thicknesses Layer Thicknesses@
o pee—— nz -~
Trend for 1" Axis:
rend for Wz 90 05
nz
nz
nz -
I k. I [ Cancel
Select Element by Index

This feature allows you to select an object element (cell, vertex, face) by index enabling you to inspect

properties, location etc.

Type: |Faces 7)

Index: O 0-2
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Fault movement improved with non-stretch option

The fault movement feature has been improved with an option that allows the original “stretch” option
(vertices along the fault only were moved) as well as a new method where all vertices on the offset side
of the fault are moved creating a more standard fault operation

Merge Surfaces
In some cases multiple surfaces will in fact make up a single surface object — select the surfaces you
want to merge together and a new object will be created that is the union of both originals.

Filter Property Values
In order to fill in missing data or substitute values in particular ranges with other values you can now
select “Filter Values” from the property edit dialog.

i ™
Filter Property T — u

Property: MyProp

Values to Replace:

(71 Values Matching

Replace With:

(@ Mearest Valid Value

() Mearest Value Matching

() Scalar Constant distribution

(71 Computed Value

Values to Replace
e Invalid Values — the property will be scanned for invalid flagged values and replaced.

e Values Matching — the entered function will be evaluated at each element and non-zero values
will be replaced
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Replace With

e Nearest Valid Value — Flagged values will be replaced with the nearest non-invalid value from
the object

e Nearest Value Matching — the entered function will be evaluated at each element and flagged
values will be replaced by the nearest value where the evaluated function is non-zero.

e Scalar — Flagged values will be replaced by a random number.

e Computed Value — Flagged values will be replaced by the value of the entered expression

Fracture Generation

Update P32 for Truncated Distributions
This is an automated version of the P32Cutt spreadsheet which calculates a p32 reduction factor based
on any truncated distributions used in the fracture set definition.

Improved Tessellated Fracture Sets
Tessellated fracture sets now have a smaller memory footprint and performance of
stratigraphic/tracemap generation.

Stored Generation Seed

The seed value that was used to generate a fracture set is now stored during generation and displayed
in the attributes window. These seed values can be used to recreate a given fracture set for a single
version of FracMan — seed values are not generally conserved between releases.

Improved Spatial Bootstrapping
New bootstrapping options include selecting a random point weighted by distance or distance squared.

Hydro Fracture

Smooth Outline
This option will cause generated hydro fracs to have a more rounded appearance.
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Other HF improvements?

MAFIC

Import MAFIC Particle Tracking

MAFIC particle tracking files (tracks.pcl) can now be imported as point data sets from the File -> Import -
> Point Data menu or from a MAFIC definition by selecting “Import Particle Track(s)” from the Mafic
Definition menu.

Import for MAFIC Timesteps
Any/all timesteps can be imported by selecting “Import Timestep Pressures” from the MAFIC definition

menu.

Interface for Edmesh mesh cleanup

A basic Edmesh mesh cleanup / operation can be applied (after meshing is complete) by selecting
“Optimize Mesh” from the MAFIC definition menu. This operation will run Edmesh’s “Merge and
Remove Floaters” function which will merge nodes closer than 1e-4 and will remove invalid triangles
with area less than 1e-10. These are the most common Edmesh operations — additional operations can
be applied by running Edmesh from the command line directly.

Visualization

Well Log Lathe display

This is a display that shows the well log as a 3 dimensional “pipe” of varying radius along the well. When
the well log is selected, select a property from the “Pipe Prop” pull down in the attributes window. You
can adjust the size of the pipe by changing the value specified in “Default Size”. This mode will also
color by any property selected in the color map.
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Attributes *
Vi -12156.8 - 1376.84 -
Size: 701.831, 320574, 13533.7
ey
= Appearance i
Filled
Wireframe
Outline ~None—
Lit Trend
Plunge: =
Fill Color Depth
Wireframe Caolor Terzaghi
Outline Colar X
Count ;
MinDepth Length_D
MaxDepth FraclD_D I
DetaDepth Terzaghi_0
' x_0
Default Size Y0
Size Prop Z0
Ribbon Prop N _?;PEITUI'{B N
Ribbon Prop § goremssvy
" Ribbon Prop E
< Ribbon Prop W Face_Radius
w0 Fipe Prop —MNone—

Well Log Ribbon display
This mode shows the well log as a 2 dimensiona

Ill

Ribbon” of varying size along the well trajectory. You
can visualize up to 4 different properties at a time (1 for each compass direction). This mode will also
use the color property specified by the Legend bar.
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Point Data Display Percent
You can improve performance by displaying only a selected percentage of a point data set. Enter the
desired display percent in the attributes bar.

License System

Online Demo activation
Demo licenses are now activated online using the registration dialog box. The user enters their email
address in the box provided and presses “Activate Online”.
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|

Activate Online: 740.2011.04. 13

i@ Activate Demo License

Email: | niosephson@golder. com|

(™) Activate Permanent License

License IC: Password: | test

| Actvate Online... |
Manual Activation
bEkpe v, Fracman, corn)slfunlock, asp
User Cods 1 | 237235126 | Regkey | |
User Code 2: | 105545241 | Reakeyz: | |
Req Key 3 | |
Reg kew 4: | |
Fed kKey 5 | |
Reg Key & | |
Activate Req Key 7 | |
mailto:register @fracman. com I Close I

Demo activation from special USB dongle
This provides the ability to activate a demo license using specially encoded “workshop” dongle.

USB dongle update from online system
Updates to USB dongle based licenses can now be applied from the online system

FlexLM license system
Available by special request only
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Other

Improved Curvature calculation
The curvature calculation has been improved to interpolate curvature values along surface edges from

nearby non-edge vertices.

Well Log Interval Properties
Intervals now have properties that provide the xyz coordinates of the interval top and bottom points,

these properties can be exported, visualized, etc.

Grid Layer Property report

this will report the mean/min/max/count of all properties of a grid, layer by layer. Select a grid object in
the objects bar and select “Grid Layer Property Report” from the Static Analysis -> Grid menu. The
report will exclude inactive and invisible cells.
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